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SUBJECT: Layer Masks and Their Relatives
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Context

·  Different parts of an image may call for different treatments.

Forces

·  An image needs several adjustments.

·  Each adjustment may apply to only part of the image.

·  Adjustments are made sequentially but may interact with one another.

·  Adjustments made on a single version of an image cannot be changed later.

Problem

·  To make selective adjustments on Photoshop images in such a way that they can be
modified later, out of sequence.

Solution

·  Use masks on separate layers to achieve selective, modifiable adjustments.

Related Patterns

·  Zone system.

In this paper, we will ill ustrate with three images various aspects of layer masking. Then
we will finish with an exercise that will help the reader practice and consolidate on
his/her own image the possibiliti es that we have ill ustrated.
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·  Image #1, Reduce Very High Contrast (View from Banff Springs), shows the use of
layer masks. I included it mainly to provide continuity to aspects touched on in the
last meeting, on blending modes.

·  Image #2, Add Impact to a Tired Image (Mandalay Bay), shows the use of multiple
layer masks in the development of a single image.

·  Image #3, Create a Striking Effect (Montmartre Street 13), shows the use of a
clipping layer.

·  Image #4, You Try It Now (Mosaic Mask), is a mask that the motivated reader can
use to practice the techniques ill ustrated in the three foregoing cases.

Image #1: Reduce Very High Contrast

Figure 1. Final image: View from Banff Springs

Challenge and go al
The original photo was taken in conditions of extreme contrast between the interior of the
hotel and the scene outside. The photo was exposed for the outdoor scene, so the interior
features appeared almost entirely black on the film scan, even though I used high-latitude
print film. My goal was to try to retrieve some of the interior detail .

Step-by-step
The task was to reduce contrast between indoors and outdoors.
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1. I first tried to do this with a Curves adjustment, but it was not particularly successful.
So I added a contrast mask (see 2002-13: Blending Modes). It helped, but not enough.
Well , if one contrast mask was an improvement, wouldn’ t two be better? So I tried a
second contrast mask, and it did help the interior, but nasty halos started to appear
around the mountains outdoors.

2. To get rid of the halos, I created layer masks on each of the contrast mask layers, to
keep the contrast mask from operating on the outdoors. (Masks on masks?—but no
worry: we’re talking about two different kinds of masks here. Contrast masks are not
layer masks; the others are.)

3. As a final touch, I created separate curves adjustment layers for the interior and the
exterior (different adjustments are required in these two areas of the image, so I used
a pair of layer masks that are the negative of each other to control tonali ty separately
in these two areas.

Figure 2. Layers palette for View from Banff Springs

End result
The image ended up with a total of f ive layers: (1) the original image, which had been
sharpened; (2) a Curves adjustment layer for the foreground; (3) a Curves adjustment
layer for the background; (4) a contrast mask that excluded the exterior; and (5) a second,
identical contrast mask. I put the two contrast masks in a layer set since they were very
similar in nature (they cannot be merged without losing their double effect) and since
consolidating them into a set would simpli fy the presentation of the Layers palette. There
are also four layer masks: one for each layer except the basic image layer. Three of them
are the identical mask; the fourth is simply the negative of the other three. See their
thumbnails in Figure 2.

The resulting final image showed a surprising amount of interior detail without creating
unpleasant artifacts in the outdoor scene—though revealing a good bit of grain. Not a
great picture, but a lot better than what I started with.
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Image #2: Add Impact to a Tired Image

Figure 3. Final image: Mandalay Bay

Challenge and go al
The original image lacked oomph: it was muddy and dull . My goal was to increase
impact. I decided to do this by restoring brilli ance to the mirrored gold planes of the
hotel, putting contrast in the sky, and brightening the overhead rails so that they would
draw the viewer's eye toward the hotel.

Step-by-step
1. I found that although the hotel and rails needed sharpening, sharpening did the grain

in the sky no favors. So we created a layer mask to block out the sky and sharpen
only the foreground areas of the image. (Layer name: Sharper image.)

2. I created a mask to exclude the sky and used it on a Curves adjustment layer to
increase the contrast of the sky. (Layer name: Contrast sky.)

3. I created a HSB layer to enhance the blueness of the sky, and used no mask for it
since there were no significant other blues in the image. (Layer name: Color sky.)

4. I created a layer mask to include the hotel and rails and used it on another Curves
adjustment layer to brighten the hotel. (Layer name: Brighten hotel.)

5. Finally, I created another Curves adjustment layer to further brighten the rails, using a
mask that allowed only the rails to be affected. (Layer name: Brighten rails.)
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Figure 4. Layers palette for Mandalay Bay

End result
The image ended up with five auxili ary layers and four masks: one mask on the
sharpened layer, the other three on adjustment layers. All four masks differed in at least
some respect from the others.

The resulting final image was brighter and sharper than the original; I got the extra
oomph that I wanted.

Image #3: Create a Striking Effect

Figure 5. Original image
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Challenge and go al
This marginal snapshot was to become one in a series of surreal versions of a view of an
ordinary street scene in the Montmartre area of Paris. My goal was to give it extreme
impact, in a way that differed from any of the other image treatments in the same series.

Figure 6. Final image: Montmartre Street 13

Step-by-step
1. The idea: Put part of the image in strongly contrasting color treatment to the rest. The

featured part should be bright in color, the rest duller. The bright area should be
smaller in area than the duller background. The edge dividing the two sub-areas
should be abstract and irregular so as not to require mental work by the viewer to
recognize it, thus distracting from the basic image and the effect.

2. The colored layer: (This part, though interesting, is not directly related to the topic of
this paper, Masking Layers.) I decided to use indexed color for the brightly colored
part. I made a copy of the basic image in another document, desaturated it, changed
its mode to Indexed Color, and used the Color Table to map the black/white spectrum
to black > red > yellow > white. I then converted the brightly-colored image back to
RGB mode and copied back to the original image as a separate layer, which I put
above the layer that was to become the background.

3. The background layer: Manipulation of the background layer was simple. I
desaturated the image, then inverted it to produce a negative image. However, it was
so far behind the colored layer, so I couldn't see it.

4. The figure/ground shape: Since I wanted an abstract and irregular patch of color, I
scanned a swatch I had made with a paintbrush fill ed with black tempera paint on a
sheet of regular paper. I then brought the scan into Photoshop, adjusted it to the right
size, and removed the background, so that now I had a black swatch against a
transparent background. I then placed it below the colored layer, and joined it to the
colored layer as a clipping group. Once this clipping layer was in place, I improved
its impact further by adding to it a slight drop shadow and embossing effect.
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5. Final tuning: I then placed an adjustment layer, without a mask, above the colored
layer to reduce the saturation a bit and bring the colored part of the image back into
gamut for my printer. This adjustment layer required no mask.

Figure 7. Layers palette for Montmartre Street 13

End result
The final image consisted of just four layers, one of which acted as a mask to separate the
colored part from the B/W part. Instead of a clipping group, I could have used a layer
mask for the separation, but I would have had to modify the swatch: replace its
transparency by white, then invert the whole thing. Then any layer blending effects
would be applied to the whole layer, instead of only the swatch, as it was done with the
clipping group.

The image speaks for itself: it does catch the viewer's attention. There is some question,
however, whether it should be called a “photograph.”
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Image #4: You Try It Now

Figure 8. Mosaic Mask

Use this separated mosaic image, or another image of your choice, if you prefer, to
separate parts of an image of your own for separate treatment. Experiment with using it
either as a layer mask or in a clipping group, to learn how to do both, and to understand
differences in what you can accomplish with the two approaches. Bring your results to
the next meeting and tell the group about what you learned.

Hands On: How to Mask Layers
Here are some mercifully brief comments on the hands-on mechanics of working with
layer masks, clipping groups, and quick mask:

Layer masks/Alpha channels
There are various ways to make a layer mask. Generally, they involve making a selection,
then installi ng that selection as a mask. Here are some ways:

1. Select a layer you want to mask in the Layers palette and click the icon at the bottom
of the palette that looks like a circle within a rectangle. This creates a white mask, to
which you will need to add black areas (i.e., areas that mask out that part of the
layer).

2. From the menus select Layer > Add Layer Mask > Reveal All (or Hide All ). If you
select Reveal All , the mask will be all white, and you will need to add black areas to
it to remove those areas you want to hide. If you select Hide All , the mask will be all
black, and you will reveal parts of the layer by adding white.

3. Select part of the image by whatever means you prefer (magic want, Lasso, Pen, etc.),
then from the menus choose Select > Save Selection. The selection will t hen become
a channel (known as an Alpha channel) which you can use to recall and reuse that
selection later.
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4. Select part of the image by whatever means you prefer, as before, then make an
adjustment layer. The adjustment layer will immediately inherit a layer mask defined
by the selection that was in effect when you made it.

There are many variations on these possibiliti es, plus other possibiliti es. Experiment.
Practice.

Notice the duali ty between selections, channels, and masks. A selection, if saved,
becomes a channel, known as an Alpha channel. A selection that has not yet been saved
can be rendered as a special channel known as a Quick Mask channel. An Alpha channel
is permanent, a Quick Mask channel persists only as long as a selection is in effect. Learn
and internalize these relationships.

Clipp ing g roup s
To create a clipping group do one of the following:

1. Hold down Alt, position the pointer over the line dividing two layers in the Layers
palette (the pointer changes to two overlapping circles ), and click.

2. Select a layer in the Layers palette, and choose Layer > Group with Previous.

3. Link together the desired layers in the Layers palette. (See Linking layers.) Then
choose Layer > Group Linked.

The clipping group is assigned the opacity and mode attributes of the bottommost layer in
the group. Note that, unlike a layer mask, the action of a clipping group is determined not
by black/white difference, but by opacity: transparency hides the upper layers, opacity
reveals them. The color of the opaque part has no effect; white works the same as black.

(In addition, a path can be used as the bottommost layer in a clipping group, in which
case, it is known as a Vector Mask.)

Thus, there is a tradeoff between using layer masks and clipping groups. When is one
preferred, when the other?

Quick mask
A Quick Mask is a special kind of mask that's used to make a selection. (The
Quick Mask is one of my two favorite selection tools, the other one being the
Pen tool.)

To use Quick Mask, click the right-hand icon near the bottom of the tool palette
that looks like an inverted Japanese flag, select a brush of your choice, change

the foreground color to black, and start painting on the area of the image you want to
select. Keep on painting, changing the size of the brush as necessary, until you finish. If
you make a mistake, change the foreground color to white and paint out your error. (A
black brush lays down a red mask on the image, a white brush undoes selected parts of
that red mask.)

When you finish painting your mask, you can return from Quick Mask mode to normal
mode by clicking the left-hand “Japanese flag” icon. Then you will see the usual
marching ants marking out the edge of your selection. If you want to save the selection to
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a permanent Alpha channel, go to the menu option Select > Save Selection, and give your
selection a name (e.g., “Sky” ). The reason I favor this tool for selection is its
reversibili ty; I make lots of errors. In addition, before you return out of Quick Mask
mode, you can go to the Channels palette and examine your selection progress in a stark
black/white rendition. This view often reveals small grains of un-selected image that you
can then get rid of, simply painting on the black/white rendition.

Exercises
The CD provided to you at the meeting on this paper contains all the layers and masks of
Images #1, #2, and #3 as discussed in this paper. The challenge is to assemble these
components in Photoshop to reproduce the final images. That makes three exercises, one
for each of the images: View from Banff Springs, Mandalay Bay, and Montmartre Street
13. The final exercise is to use the Mosaic Mask (Image #4) with an image of your own
to produce some sort of interesting composition based on layer masks or a clipping
group. The rest of this discussion of the exercises will cover only the first three images;
for the fourth, you're on your own.

The screen shots of the Layers palettes for each image provide a guide to assembly.
Here's a li st of the components for each exercise, along with some helpful comments.

Image #1: View from Banff Springs (VBS)

Image Layers
VBS Base I mage.psd
VBS Contr ast Mask. psd

Adjustment Layers
VBS Backg r ound Cur ves Adj Laye r .acv
VBS Foreg r ound Cur ves Adj Laye r .acv

Comments

·  In this and the Image #2 exercises, layer masks are saved as selections with the base
image. Creating them is work you would normally have to do with the use of any of
various selection tools. However, since this is not an exercise in selection, I've
provided the saved selections for you to use. You can use them by performing
Select > Load Selection before applying the corresponding adjustment layer or filter,
or by creating the layer mask on the layer afterwards.

·  There are four layer masks used in this picture. Three of them are the same, the fourth
is a negative of the other three.

·  A concept that may be new to you (it was to me) is that adjustment layers can be
saved as individual files and loaded. Thus, the .acv files in this exercise, and the .acv
and .hsu files in the others are loaded with the Load button on the appropriate (Curves
or HSB) adjustment layer dialog boxes.
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Image #2: Mandalay Bay (MB)

Image Layers
MB Base I mage . psd
MB Sharpe ned I mage. psd

Adjustment Layers
MB Col or Sky HSB Adj Layer . ahu
MB Contra st S ky Cu r ve Adj Laye r .acv
MB Br i ght en H otel Curv e Adj Layer. acv
MB Br i ght en R ails Curv e Adj Layer. acv

Comments

·  This is a diff icult exercise, mainly because it has so many partsÐnot because of any
new conceptual diff iculties.

Image #3: Montmartre Street 13 (MS)

Image Layers
MS Base I mage Negat ive . psd
MS Wil d C olor Imag e.psd
MS Br ush Swat ch.psd

Adjustment Layers
MS Gamut Cont r ol H SB Layer . ahu

Comments

·  After you've added the brush swatch layer to the image, use Layer Options to give it
a drop shadow and embossing.

·  Extra credit: Instead of using a clipping group, make this same picture by using a
derivative of the brush swatch as a layer mask.

If you have any problems with these exercises and would like some help, give me a call
at 842-0110, or drop me an e-mail at davidw@bainbridge.net.

David Warren
December 2002
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Addendum 1: Layer Masks—The Reader’s Digest Version
by David Warren

The Layer Masking Process
1. From the CD, open the image named VBS Base Image

2. Brighten up the indoors
2.1. Load the selection Reveal Indoors (Select > Load Selection)
2.2. Create a curves adjustment layer
2.3. Brighten up the indoors (pull up the middle of the curve) until detail shows in the

walls, chairs, etc.

3. Brighten the color of the outdoors
3.1. Load the selection Reveal Outdoors (Select > Load Selection)
3.2. Create a hue/saturation/brightness adjustment layer
3.3. Increase the overall saturation to, say, 40 or 50

You should now have the background layer (actually, Layer
0) and two adjustment layers, each with its own layer mask.
If you've followed the instructions above, your layers
palette should look like this.

That's all , folks! You've had to make the same selection
you would've made if you'd wanted to operate on separate
image layers. (In this exercise you didn't have to make any
selection because it was made for you, and saved in two
forms, the indoors and the outdoors.)  But you used it in a
different way.

Please don't hesitate to phone me if you have any problems
or questions.

Another Approach: Layering the Image
Tom DeVange has offered a different approach to editing

the photo. His approach is to isolate parts of the image on separate image layers and
apply adjustments to those layers. His is an alternative way of getting to the same
resultÐto brighten the interior in this photo while separately improving the rendition of
the outdoors. None of the layers in the stack contain masks, so we might call his approach
“ layered image”  instead of “ layer masking.”

The layer mask approach results in a smaller final image size, as the following figures
ill ustrate:
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Layer Mask Approach
èè  Size: 23.7 MB

Layered Image Approach
èè  Size: 48.8 MB
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Addendum 2: A “ Cut and Paste” Approach to Layer Masks
by Tom DeVange

This description of a layer mask procedure uses David Warren's VBS image.

I never alter the background layer.  I save it so that I can return to it i f I have any
problems.

1. Make two copies of the Background layer.  Title one ªOutside View” and the other
ªInterior.”  Stack them so ªOutside View” is above Background and ªInterior” is above
ªOutside View.”

2. Turn off all l ayers except ªOutside View.”  Make Outside View layer active.  Use a
selection tool to select the view through the window.  (I li ke the free-hand lasso tool
because it is fast.)  Get close to the edge (just outside the window frame, i.e., leaving a bit
of the wall ) but don't worry about perfection because you will clean up the edge later.
Invert the selection and delete by pressing the backspace key.  This will eliminate
everything except the view through the window and the edge you left.  Now unselect the
selection so that editing can easily proceed.  Increase magnification to 300 or 400%.  Use
the Eraser tool and a hard-edged brush to trim around the window.  Just leave a thin
margin of wall around the edge.  (This is to allow leeway in case you remove too much
on the next layer.)  Go to a level of magnification which fill s the screen with the window
image.

3. Use the Magnetic Lasso to select the near mountain on the right and foreground in the
view through the window.  (The sides and bottom of the selection are the window frame.)
Open an adjustment layer for Brightness & Contrast (select ªGroup with Previous
Layer”) and lighten the shadows a bit by increasing brightness and reducing contrast.  I
used +20B & -7C.  Click OK.  Then use the Magnetic Lasso to select the sky and distant
mountains.  (The top of the selection is the window frame.)  Open a second adjustment
layer (select ªGroup with Previous Layer”) and add some contrast to the sky to make the
clouds stand out more.  I used +4C.  Click OK.

4. Turn the ªOutside View” layer off and the ªInterior” layer on.  Repeat the selection
process you used in Step 2, but this time use the magnetic lasso around the window
where the frame meets the outside view.  Press the backspace key to delete the view
through the window.  Now deselect the selection.  Magnify to 300 or 400% and use the
eraser tool and a hard-edged brush to trim all traces of exterior view from the edge of the
window frame.  (Any errors will be buried in the edge you left on the other layer.)
Return to a normal-sized view.  Reselect the selection.  Open an adjustment layer for
Curves (select ªGroup with Previous Layer”) and adjust to lighten the interior as much as
possible without making the image look odd.  I used two adjustment points.  One was
input 46 & output 91.  The other was input 170 & output 191.  Click OK.

5. Create a contrast mask for the ªInterior” layer.  Do this by following David's rendition
of the material from Luminous Landscape:

Duplicate the ªInterior” layer and name it ªContrast Mask.”  (Make sure this new
layer is on top of all others.)
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Make ªContrast Maskº the active layer.  Go into Image > Adjust > and select
Desaturate.

Go into Image > Adjust again and select Invert.

Double-click on the ªContrast Maskº layer on the layers palette and select Layer
Options.  In the Mode box, select Overlay.

Go to Filter > Gaussian and select it.  Pick a value between 10 & 30 that looks
good to you.  I used 30.  Click OK.

Play with the Opacity percentage of this layer to see if you like it at some point
less than 100%.  I left it at 100%.

6. Turn the ªOutside Viewº layer on and you have your final, modified image.  (Grouped
adjustment layers automatically go on and off when you turn their main layer on and off .)

7. You will need to sharpen the image to print it.  In a case like this, where I am
sharpening the entire image, I create a temporary layer for this purpose.  Create a new
layer (new, not a duplicate of any other layer) and call it ªSharpen.º  Make sure it is on
top of all other layers and that all other layers (except the Background) are on.  While
depressing the ALT key, use the mouse to select ªMerge Visibleº on the layers palette
menu.  This copies all visible layers to the single new layer.  Then apply the Unsharp
Mask filter to this new layer.  I used 75, 1.5, 4 for the settings.  Since I know my printer's
idiosyncrasies, I also create an adjustment layer (grouped with the ªSharpenº layer) for
Brightness/Contrast and add +3B.  I throw the ªSharpenº layer away after printing.

NOTE:  In some images you will want to sharpen or avoid sharpening certain areas.  In
such cases I sharpen only a layer or a selected part of a layer.  I can also sharpen different
layers or selections to different amounts.  In these cases I work with a previously saved
image and then simply click ªNoº when I close the image and Photoshop asks if I want to
save the changes.
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Addendum 3: Restating the Procedure from the Original Paper
by Ken Hales

Modification o f the Process
In Step 3.2 of ªLayer Masks: The Reader's Digest Versionº substitute the following:
ªCreate a curves adjustment layerº

In Step 3.3 of the above substitute the following:  ªBrighten up the indoors (pull up the
upper portion of the curve)º

Completion o f the Process
First Contrast Mask:
- Make Layer 0 the active layer.
- Layer/Duplicate Layer.  Name it Contrast Mask 1.  Drag it to top of Layer Stack
- Make new layer active
- Image/Adjust/Desaturate
- Image/Adjust/Invert
- Right-Click on the Contrast Mask Layer.  Select Blending Options.  Select Overlay
Mode
- Filter/Blur/Gaussian Blur – usually a value between 10 and 30

Second Contrast Mask:
-Repeat above.  Name the Layer Contrast Mask 2

Protect the exterior
- Make Contrast Mask 1 active
- Load the Selection Reveal Indoors
- Create mask (Layer/Add Layer Mask/Reveal Selection)
- Repeat for Contrast Mask 2

Group the two Contrast Mask layers
- Let any layer be active
- In Layer Palette select diamond and New Layer Set.  Name Contrast Mask
- Drag the new layer set to the top of the layer stack
- Drag the two Contrast Mask layers up to the Contrast Mask set

Observe that the final file is ªequivalentº to the VBS Final file both visually and
structurally


